FloripaSat-1 custom-made software on LINUX #22019年12月22日 19時58分



Re: FloripaSat-1 software
From: PE0SAT Amateur Radio
To: Mineo Wakita
Date: Sun, 22 Dec 2019 11:11:37 +0100

Good morning Mineo, 
Finally with some help I was able to get it running. 
There are requirements and dependencies that need to be in place. 

First: It needs python2 as the default and not 3 as it is in Ubuntu 18
as far as I know. 

user@locutus:~$ python --version
Python 2.7.17 

My suggestion is to start the FloripaSat app from the command line and
see what kind of errors you get and go from there 

user@locutus:~$ which floripasat-grs
/usr/local/bin/floripasat-grs 

On my system it also needed a GNURadio 3.7 environment to get it running
but others where successful with 3.8 

It is possible but not very clear. 

More information can also be found at:
http://github.com/floripasat/grs/issues

Let me know if you need more information, good luck. 

73 Jan 

On 22-12-2019 10:59, Mineo Wakita wrote:

> Hello, 
> 
> I built "floripasat-grs_0.7-0_ubuntu18.04.deb" in My_LINUX PC,
> and did "Effect_Nomalize" 1k2_GMSK EPS file received by DK3WN
> as "floripa2.wav" using Audacity software on LINUX.
> http://dl.dropbox.com/s/sy6lp8q1ecskan9/floripa2.wav
> 
> Can you decode this wave file using FloripaSat-1 software?
> 
> http://floripasat.ufsc.br/
> http://github.com/floripasat/grs/wiki
> http://github.com/floripasat/grs/releases
> 
> JE9PEL, Mineo Wakita